modAlertify

Уведомления AlertifyJS, Notify, Overhang, Noty или Toastr
Версия 1.0.4-beta
Дата выпуска 02.07.2018
Загрузки 189
Просмотры 1 549
Внимание, этот компонент требует версию PHP 5.4 или выше! Если ваш сайт использует PHP ниже требуемого, установка этого дополнения может его сломать.
Внимание, этот компонент требует версию MODX не ниже 2.5 !

modAlertify


Дополнение заменяет уведомления jGrowl (использующиеся в miniShop2, Office, AjaxForm) на AlertifyJS, Bootstrap Notify, Overhang JS, Noty или Toastr.
modAlertify не заменяет стандартные скрипты дополнений, а только переопределяет методы вывода сообщений.


В системных настройках можно указать заменять ли уведомления каждого из дополнений (modalertify_minishop2, modalertify_office, modalertify_ajaxform), указать настройки по-умолчанию для alertify в формате JSON (modalertify_options), задать тему alertify (modalertify_theme)


1.0.4-beta

  • Added notices: Bootstrap Notify, Overhang JS, Noty, Toastr
  • Fixed plugin
  • Fixed /web/default.js

1.0.3-beta

  • Fixed /web/default.js

1.0.2-beta

  • Fixed /web/default.js

1.0.1-beta

  • First release

Последние обсуждения в сообществе MODX.pro